Good to Know Database

VMware Player 1.0.2: Installationsprobleme unter Kanotix


Problem:

/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)

Lösung:

Öffnen Sie als root die Datei /usr/lib/vmware/lib/wrapper-gtk24.sh in einem Editor und suchen folgenden Abschnitt.

vm_run() {
    local exitCode;

Fügen Sie dort die folgenden Zeilen ein.

   # Fix for vmplayer pulling in libdbus-1.so.2 instead of .3
   export LD_PRELOAD=/usr/lib/libdbus-1.so.3:$LD_PRELOAD

Das Ganze sollte anschließend wie folgt aussehen.

# Run "$binary" while watching its progress on its stderr.
vm_run() {
   local exitCode;

   # Fix for vmplayer pulling in libdbus-1.so.2 instead of .3
   export LD_PRELOAD=/usr/lib/libdbus-1.so.3:$LD_PRELOAD

   # Append any libraries that are still missing.
   if [ "$VMWARE_USE_SHIPPED_GTK" = 'force' ]; then


Dieser Eintrag wurde am 26.10.2006 erstellt und zuletzt am 10.06.2009 bearbeitet.

Direkter Link zu dieser Seite: http://www.gtkdb.de/index_7_101.html

[ Zur Startseite ]   [ Zur Kategorie ]


Valid XHTML 1.0 Transitional Valid CSS Valid Atom 1.0

© 2004-2018 by Georg Kainzbauer