Good to Know Database

Raspbian Jessie: System startet im Emergency Mode nach RAID-Konfiguration


Wenn Sie wie in der Anleitung Raspbian Wheezy: Software RAID konfigurieren mehrere USB-Datenträger an einem Raspberry Pi in einem RAID-Verbund betreiben, könnte es vorkommen, dass der Systemstart an der folgenden Meldung für 1 Minute 30 Sekunden stehen bleibt.

A start job is running for dev-md0.device (28s / 1min 30s)

Sollte dies der Fall sein, erhalten Sie am Ende des Bootvorganges die folgende Ausgabe und der Zugriff über SSH wird verweigert.

Welcome to emergency mode! After logging in, type "journalctl -xb" to view
system logs, "systemctl reboot" to reboot, "systemctl default" to try again
to boot into default mode.
sulogin: root account is locked, staring shell
root@raspberrypi:~#

Die Ursache für die Verzögerung des Systemstarts liegt darin, dass die USB-Datenträger zu spät erkannt werden und folglich der RAID-Verbund nicht gestartet wird. Dadurch kann bei der Abarbeitung der /etc/fstab das Dateisystem auf dem RAID-Verbund nicht eingehängt. Der vermeintlich fehlerhafte Eintrag in der /etc/fstab ist letztendlich die Ursache, dass Raspbian im Emergency Mode gestartet wird.

Damit Raspbian wieder im Default Mode startet, könnten Sie den Eintrag für das RAID-Dateisystem in der /etc/fstab auskommentieren. Damit aber das Problem behoben wird und auch der RAID-Verbund genutzt werden kann, müssen Sie den Bootvorgang etwas verzögern damit alle USB-Datenträger erkannt werden. Öffnen Sie dazu die Konfigurationsdatei /boot/cmdline.txt mit einem Editor.

root@raspberrypi:~# vi /boot/cmdline.txt

Standardmäßig sollte hier die folgende Zeile enthalten sein.

dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait

Erweitern Sie diese Zeile um die Option rootdelay=5 und speichern die Datei ab.

dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait rootdelay=5

Starten Sie jetzt den Raspberry Pi neu und prüfen ob nach dem Neustart der RAID-Verbund erkannt und eingehängt wurde.

root@raspberrypi:~# shutdown -r now

Sollte das Problem nicht behoben sein, erhöhen Sie den Wert von rootdelay in der /boot/cmdline.txt und führen erneut einen Neustart durch.


Dieser Eintrag wurde am 16.09.2016 erstellt und zuletzt am 25.09.2016 bearbeitet.

Direkter Link zu dieser Seite: http://www.gtkdb.de/index_36_2828.html

[ Zur Startseite ]   [ Zur Kategorie ]


Valid XHTML 1.0 Transitional Valid CSS Valid Atom 1.0

© 2004-2018 by Georg Kainzbauer